Status page moved

Incident Report for Hourglass

Identified

This status page has been moved to https://status.chlod.net/.
Posted Apr 05, 2023 - 03:04 UTC

Investigating

This status page has been moved to https://status.chlod.net/.
Posted Apr 05, 2023 - 03:04 UTC